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File Manager - это графическая оболочка, представляющая большинство

функций MS DOS для работы с файловой системой MS DOS.

Имя программного файла - WinFile.exe. Иконка,отображающая WinFile.exe,

находится в группе Main (Program Manager).

На рис.1 представлен внешний вид иконки File Manager.

Рис.1
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В рамках данной темы рассматривается версия File Manager из MS WINDOWS

FOR WORKGROUPS. File Manager из MS WINDOWS отличается практически толь-

ко тем, что отсутствуют средства,обеспечивающие работу в сети.

File Manager - это MDI-приложение. Дочерние Окна “отражают” содержание

текущего каталога заданного диска.

На Рис.2 представлен внешний вид Главного Окна File Manager.

Рис.2
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На рис.3-9 представлен внешний вид Меню File Manager.

В табл.1 приведено назначение всех пунктов Меню. 

Рис.3
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Рис.4
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Рис.8




Рис.9




                                               Табл.1

N п/п
Пункт Меню
Назначение

1
File -> Open
“Запустиь” помеченный программный файл на выполнение.

2
File -> Move
Переместить помеченный(е) Файл(ы) или Каталог

3
File -> Copy
Скопировать помеченный(е) Файл(ы) или Каталог

4
File -> Delete
Удалить помеченный(е) Файл(ы) или Каталог

5
File -> Rename
Переименовать помеченный(е) Файл(ы) или Каталог

6
File -> Properties
Свойства помеченного Файла или Каталога

7
File -> Run
“Запустиь” программный файл на выполнение.

8
File -> Print
Вывод на Принтер помеченного до-кумента(ов)

9
File -> Associate
Создать “ассоциативную связь” между файламиопределенного типа

и программой-обработчиком

10
File -> Create Directory
Создать Каталог

11
File -> Search
Выбрать файлы по маске и раз-местить их имена в отдельном списке

12
File -> Select Files
Пометить файлы в текущем ката-логе активного диска по маске

13
File -> Exit
Выход из File Manager(закрыть)

14
Disk -> Copy Disk
Посекторное копирование FDD

15
Disk -> Label Disk
Изменить метку диска

16
Disk -> Format Disk
Форматирование FDD

17
Disk -> Make System Disk
Перенос ядра MS DOS на FDD

18
Disk -> Connect NetWork Drive
Сетевое соединение с разделенн-ыми логическими дисками другого компьютера

19
Disk -> Disconnect NetWork Drive
Рассоединение с разделенными логическими дисками другого компьютера

20
Disk -> Share As
Разрешить сетевой доступ к соб-ственному активному логическому диску(разделение доступа)

21
Disk -> Stop Sharing
Запретить сетевой доступ к собственным логическим дискам

22
Disk -> Select Drive
Выбор активного диска

23
Tree -> Expand One Level
Показать один уровень подкатало-гов текущего каталога

24
Tree -> Expand Branch
Показать все подкаталоги(ветви) текущего каталог

25
Tree -> Expand All
Показать полное дерево каталогов (все ветви) 

26
Tree -> Collapse Branch
Скрыть все подкаталоги(ветви) текущего калога

27
Tree -> Indicate Expandable

Branches
Помечать(символом +) все катало-ги,имеющие подкаталоги

28
View -> Tree and Directory
Показывать в активном дочернем окне Дерево Каталогов,Каталоги и Файлы активного логического диска

29
View -> Tree Only
Показывать в активном дочернем окне только Дерево Каталогов активного логического диска

30
View -> Directory Only
Показывать в активном дочернем окне только Каталоги и файлы активного логического диска

31
View -> Split
Перемещение границы раздела в активном дочернем Окне между Деревом Каталогов и содержимым текущего каталога

32
View -> Name
Степень детализации информации в активном дочернем окне : ТОЛЬКО ИМЕНА

33
View -> All File Details
Степень детализации информации в активном дочернем окне : ПОЛНАЯ ИНФОРМАЦИЯ

34
View -> Partial Details
Степень детализации информации в активном дочернем окне : ЗАДАНО ПОЛЬЗОВАТЕЛЕМ

35
View -> Sort by Name
Сортровка содержимого текущего Каталога по имени



36
View -> Sort by Type
Сортровка содержимого текущего Каталога по расширению

37
View -> Sort by Size
Сортровка содержимого текущего Каталога по размеру файла

38
View -> Sort by Date
Сортровка содержимого текущего Каталога по дате создания

39
View -> By File Type
Объекты, отображаемые в активном дочернем окне : каталоги, прог-раммные файлы, документы, иные файлы,скрытые файлы 

40
Options -> Confirmation 
Установить(отменить) запросы на подтверждение намерений Пользо-вателя

41
Options -> Font
Выбор шрифта для отображения информации в дочерних окнах

42
Options -> Customize ToolBar
Изменить cодержимое ToolBar

43
Options -> Toolbar
ВКЛ-ВЫКЛ  ToolBar

44
Options -> Drivebar
ВКЛ-ВЫКЛ  Drivebar(иконки логи-ческих дисков)

45
Options -> Status Bar
ВКЛ-ВЫКЛ  Строки Статуса

46
Options -> Open New Window on Connect
Открыть новое окно при сетевом соединении на диск иного ком-пьютера

47
Options -> Minimize on Use
Минимизировать File Manager при запуске другой программы

48
Options -> Save Settings on Exit
Запомнить текущие настройки при выходе из File Manager

49
Window -> New Window
Открыть новое окно

50
Window -> Cascade
Расположение Окон Каскадом

51
Window -> Tile Horizontally
Расположение Окон “черепицей” по горизонтали

52
Window -> Tile Vertically
Расположение Окон “черепицей” по вертикали

53
Window -> Arrange Icons
Выравнивание Иконок

54
Window -> Refresh
“Обновить” содержимое АКТИВНОГО Окна

На рис.10 представлен внешний вид Меню, ToolBar, линейки иконок

логических дисков(Diskbar).

На рис.11 представлена “расшифровка” отдельных кнопок ToolBar.

“Расшифровка” совпадает с наименованием соответствующего пункта

меню.

Рис.10




Рис.11




На рис.12 представлены иконки, отображающие различные типы

логических дисков. На рис.13 представлена строка состояния.

В строке состояния высвечивается информация об активном диске.

Рис.12




Рис.13




          ПРАКТИЧЕСКАЯ РАБОТА С FILE MANAGER
                КАК СОЗДАТЬ НОВОЕ ДОЧЕРНЕЕ ОКНО

1. “Выбрать” меню WINDOW -> NEW WINDOW,

2. “Выбрать” меню OPTIONS -> OPEN NEW WINDOW ON CONNECT.

   В этом случае новое окно будет создаваться при каждом сетевом

   соединении.

                       КАК “ВЫБРАТЬ” ДИСК
1. Сделать активным соотвествующее дочернее окно(которое будет

   отображать информацию данного диска)

2. “Выбрать” соответствующий диск одним из следующих способов :

   2.1  “Щелкнуть” мышкой по соотв.иконке в Drivebar(рис.10),

   2.2  “Выбрать” соотв.диск в ComboBox “Диски”(рис.10),

   2.3  “Выбрать” меню DISK -> SELECT DRIVE(рис.5),

   2.4  Нажать клавишу CTRL и, удерживая ее, нажать клавишу,соотв.

        данному диску.

                    КАК СДЕЛАТЬ КАТАЛОГ ТЕКУЩИМ
1.  Дважды “щелкнуть” мышкой по иконке(или имени) соотв.каталога

    в списке каталогов(файлов) - правая часть дочернего окна.

2.  “Щелкнуть” один раз мышкой по иконке(или имени) соотв.каталога

    в дереве каталогов(файлов) - левая часть дочернего окна.

3.  Используя клавиши управления курсором - переместиться в заданный

    каталог(если “курсор” находится в области дерева каталогов - левая

    часть дочернего окна).

4.  Используя клавиши управления курсором - переместиться в заданный

    каталог и нажать клавишу ENTER(если “курсор” находится в области 

    списка каталогов - правая часть дочернего окна).

             КАК ПОМЕТИТЬ(ВЫБРАТЬ) КАТАЛОГ ИЛИ ФАЙЛ
1. “Щелкнуть” один раз мышкой по иконке или имени соотв.каталога или

   файла.

2. Используя клавиши управления курсором - переместить курсор на

   соотв.каталог или файл.

      КАК ПОМЕТИТЬ(ВЫБРАТЬ) НЕСКОЛЬКО КАТАЛОГОВ ИЛИ ФАЙЛОВ
                   ВЫБОР ФАЙЛОВ ПО МАСКЕ
1. Сделать активным соотв.дочернее окно.

2. “Выбрать” меню FILE -> SELECT FILES на экране появится

   окно диалога(рис.14). Пользователь должен ввести маску

   для выбора файлов и “нажать” кнопку SELECT(для того,чтобы снять

   отметку с файлов - “нажать” кнопку DESELECT).Затем “нажать”

   кнопку CLOSE(такое имя получает кнопка CANCEL после того, как

   Пользователь “нажал” кнопку SELECT или DESELECT).

Рис.14
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     ВЫБОР ГРУППЫ ФАЙЛОВ(КАТАЛОГОВ),СТОЯЩИХ В СПИСКЕ ПОДРЯД

СПОСОБ N 1 : “Щелкнуть” один раз мышкой по строке с первым именем 

файла или каталога. Нажав и удерживая клавишу SHIFT “щелкнуть” по

последней строке с именем файла или каталога.

СПОСОБ N 2 : Используя клавиши управления курсором, “перейти”

на строку с первым именем файла или каталога. Нажав и удерживая 

клавишу SHIFT с помощью клавиш управления курсором выбрать оставшиеся

элементы группы.

             ВЫБОР НЕСКОЛЬКИХ ГРУПП ФАЙЛОВ(КАТАЛОГОВ)

1. Выбрать первую группу элементов(см.выше).

2. Нажав и удерживая клавишу CTRL “щелкнуть” один раз по первому

   элементу следующей группы.Затем,нажав и удерживая клавиши

   CTRL + SHIFT, “щелкнуть” один раз по последнему элементу группы.

3. Для выбора элементов третьей и следующих групп - повторить

   пункт 2.

         КАК УДАЛИТЬ ГРУППУ(Ы) ФАЙЛОВ ИЛИ КАТАЛОГОВ
1. Пометить группу(ы) каталогов или файлов.

2. “Выбрать” меню FILE -> DELETE. На экране появится запрос

   на подтверждение(рис.15). “Нажать” кнопку OK в окне диалога 

   DELETE(рис.15).

3. На экране появится запрос на подтверждение(рис.16). “Нажать” кнопку 

   YES или YES TO ALL в окне диалога CONFIRM FILE DELETE(рис.16).

Рис.15
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Рис.16
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ВНИМАНИЕ !!!

Если в Окне Диалога CONFIRMATION,вызываемого из меню 

OPTION -> CONFIRMATION, CheckBox FILE DELETE(DIRECTORY DELETE) 

находится в состоянии ВЫКЛ., то File Manager дополнительного 

запроса(рис.16), при удалении файлов(каталогов), делать не будет.

         КАК СКОПИРОВАТЬ ГРУППУ(Ы) ФАЙЛОВ ИЛИ КАТАЛОГОВ
СПОСОБ N 1(Drag and Drop) :
  1. Сделать видимыми “источник” и “приемник”.

     “Источник” - это файл или каталог,“приемник” - это каталог.

  2. Нажать кнопку CTRL и, удерживая ее, с помощью мыши перетащить

     (и бросить) иконку “источника” на иконку “приемника”.Отпустить

     кнопку CTRL.

  3. На экране появится запрос на подтверждение(рис.17).”Нажать”

     кнопку YES.

  4. Если в “приемнике” есть уже файл с таким именем, то на экран

     выдается запрос(рис.18). “Нажать” кнопку YES.

Рис.17
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ВНИМАНИЕ !!!

Если в Окне Диалога CONFIRMATION,вызываемого из меню 

OPTION -> CONFIRMATION, CheckBox MOUSE ACTION находится в состоянии 

ВЫКЛ., то File Manager дополнительного запроса(рис.17), при копировании файлов(каталогов), делать не будет.

Рис.18
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ВНИМАНИЕ !!!

Если в Окне Диалога CONFIRMATION,вызываемого из меню 

OPTION -> CONFIRMATION, CheckBox FILE REPLACE находится в состоянии 

ВЫКЛ., то File Manager дополнительного запроса(рис.18), при копировании файлов(каталогов), делать не будет.

СПОСОБ N 2(Меню File Manager) :
  1. “Выбрать” “источник”.

  2. “Выбрать” Меню FILE -> COPY. На экране появится Окно Диалога

     COPY(рис.19).

  3. “Включить” RadioButton To.В строке редактирования To - набрать

     полный путь к каталогу, куда копировать файл(ы) и(или) каталог(и).

     “Нажать” кнопку ОК.

  4. Если в “приемнике” есть уже файл с таким именем, то на экран

     выдается запрос(рис.18). “Нажать” кнопку YES.

Рис.19
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         КАК ПЕРЕМЕСТИТЬ ГРУППУ(Ы) ФАЙЛОВ ИЛИ КАТАЛОГОВ
СПОСОБ N 1(Drag and Drop) :
  1. Сделать видимыми “источник” и “приемник”.

     “Источник” - это файл или каталог,“приемник” - это каталог.

  2. Нажать кнопку SHIFT и, удерживая ее, с помощью мыши перетащить

     (и бросить) иконку “источника” на иконку “приемника”.Отпустить

     кнопку SHIFT.

  3. На экране появится запрос на подтверждение(рис.20).”Нажать”

     кнопку YES.

  4. Если в “приемнике” есть уже файл с таким именем, то на экран

     выдается запрос(рис.18). “Нажать” кнопку YES.

Рис.20
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ВНИМАНИЕ !!!

Если в Окне Диалога CONFIRMATION,вызываемого из меню 

OPTION -> CONFIRMATION, CheckBox MOUSE ACTION находится в состоянии 

ВЫКЛ., то File Manager дополнительного запроса(рис.20), при перенесении файлов(каталогов), делать не будет.

СПОСОБ N 2(Меню File Manager) :
  1. “Выбрать” “источник”.

  2. “Выбрать” Меню FILE -> MOVE. На экране появится Окно Диалога

     MOVE(рис.21).

  3. В строке редактирования To - набрать полный путь к каталогу,

     куда перемещать файл(ы) и(или) каталог(и). “Нажать” кнопку ОК.

   4. Если в “приемнике” есть уже файл с таким именем, то на экран

     выдается запрос(рис.18). “Нажать” кнопку YES.

Рис.21
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        КАК ПЕРЕИМЕНОВАТЬ ГРУППУ(Ы) ФАЙЛОВ ИЛИ КАТАЛОГОВ
1. “Выбрать” файл(ы) или(и) каталог(и). 

2. “Выбрать” меню FILE -> RENAME. На экране появится диалог 

   RENAME(рис.22).

3. В строке редактирования To - набрать новое имя файла(каталога).

   Можно использовать символы * и ?. “Нажать” кнопку ОК.

4. Если файл с таким именем уже есть, то на экран выдается преду-

   преждение(рис.23) и переименование не производится.

   “Нажать” кнопку ОК.

Рис.22
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Рис.23
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                       КАК СОЗДАТЬ КАТАЛОГ
1. “Выбрать” Каталог(в дереве каталогов), где будет создан

   дочерний каталог(подкаталог).

2. “Выбрать” меню FILE -> CREATE DIRECTORY. На экране появится

   диалог CREATE DIRECTORY(рис.24). “Нажать” кнопку ОК.

3. Если подкаталог с таким именем уже существует, то на экране

   появляется соотв.сообщение(рис.25). 

Рис.24
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Рис.25
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      КАК ИЗМЕНИТЬ СВОЙСТВА ФАЙЛА(ОВ) ИЛИ КАТАЛОГА(ОВ)
1. “Выбрать” Файл(ы) или(и) Каталог(и).

2. “Выбрать” меню FILE -> PROPERTIES. На экране появится 

    диалог(рис.26).

3. Изменить состояние соответствующих CheckBox(Attributes)

   и ”нажать” кнопку ОК.

Рис.26
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                  КАК НАПЕЧАТАТЬ ДОКУМЕНТ
СПОСОБ N 1 :
1. “Выбрать” Файл,соответствующий данному документу.

2. “Выбрать” меню FILE -> PRINT. На экране появится диалог 

   PRINT(рис.27).

3. “Нажать” кнопку ОК.

Рис.27
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СПОСОБ N 2(Drag and Drop) :
Этот способ возможен только в том случае, если загружен Print Manager.

1. Захватить мышкой иконку,соответствующую данному документу(в File 

   Manager),перетащить ее и бросить на иконку(или в клиентную 

   область окна) Print Manager.

      КАК “СДЕЛАТЬ” АССОЦИАТИВНУЮ СВЯЗЬ МЕЖДУ ФАЙЛАМИ

        ОПРЕДЕЛЕНОГО ТИПА И ПРОГРАММОЙ-ОБРАБОТЧИКОМ.
1. “Выбрать” меню FILE -> ASSOCIATE. На экране появится диалог 

   ASSOCIATE(рис.28).

2. В строке редактирования Files with Extension набрать расширение

   файлов, которые будут обрабатываться определенной программой-обра-

   ботчиком.

3. В ComboBox Associate With выбрать зарегистрированную программу-обра-

   ботчик(или ввести новое имя программы-обработчика,для этого можно

   использовать кнопку Browse).

3. “Нажать” кнопку ОК.

Рис.28



Информация, введенная в окне диалога(рис.28), отражается

в файле WIN.ini раздел [Extentions](см.тема N 8.12).

      КАК ВЫБРАТЬ ФАЙЛЫ ПО МАСКЕ В ОТДЕЛЬНЫЙ СПИСОК

1. “Выбрать” меню FILE -> SEARCH. На экране появится диалог 

   SEARCH(рис.29).

2. В Edit Search For ввести маску для поиска файлов.

3. В Edit Start From ввести имя Каталога,где искать.

4. “Нажать” кнопку ОК.

Рис.29


Если CheckBox Search All Subdirectories находится в состоянии ВКЛ.,

то File Manager,в процессе поиска файла, будет сканировать все подкаталоги.

Имена файлов,найденных в процессе сканирования, размещаются в отдельном

(автоматически созданном) Окне. В дальнейшем с ними можно производить

все манипуляции, которые производятся с “выбранными” файлами.

              КАК ФОРМАТИРОВАТЬ ФЛОППИ-ДИСКЕТЫ
1. “Выбрать” меню DISK -> FORMAT DISK. На экране появится диалог 

   FORMAT DISK(рис.30).

2. В ComboBox выбрать соотв.Диск(Disk In),Емкость(Capacity).

3. “Нажать” кнопку ОК.

Рис.30


Дополнительно, перед началом форматирования можно ввести имя метки

дискеты(CheckBox Label),а также указать, что после форматирования

File Manager “должен” перенести на дискету ядро MS DOS(CheckBox Make
System Disk).

               КАК “СДЕЛАТЬ” СИСТЕМНУЮ ДИСКЕТУ
1. “Выбрать” меню DISK -> MAKE SYSTEM DISK. На экране появится диалог 

   MAKE SYSTEM DISK(рис.31).

2. В ComboBox выбрать соотв.Диск.

3. “Нажать” кнопку ОК.

Рис.31


    КАК СДЕЛАТЬ ПОСЕКТОРНОЕ КОПИРОВАНИЕ ФЛОППИ-ДИСКЕТЫ
1. “Выбрать” меню DISK -> COPY DISK. На экране появится диалог 

   COPY DISK(рис.32).

2. В ComboBox Source In выбрать Дискету-источник.

3. В ComboBox Destination In выбрать Дискету-приемник.

4. “Нажать” кнопку ОК.

Рис.32


5. На экране появится запрос на подтверждение(рис.33).

6. “Нажать” кнопку YES.

7. Далее File Manager выдаст запрос(рис.34), чтобы Пользователь

   вставил Дискету-источник. Вставить Дискету-источник и “нажать” 

   кнопку ОК.

Рис.33



ВНИМАНИЕ !!!

Если в Окне Диалога CONFIRMATION,вызываемого из меню 

OPTION -> CONFIRMATION, CheckBox DISK COMMANDS находится в состоянии 

ВЫКЛ., то File Manager дополнительного запроса(рис.33) делать не будет.

Рис.34


8. Процесс считывания информации с Дискеты-источника визуально

   отображается в панели сообщений(рис.35).

Рис.35



9. После того,как информация с Дискеты-источника была считана,File 

   Manager выдаст запрос(рис.36), чтобы Пользователь вставил Дискету-

   приемник. Вставить Дискету-приемник и “нажать” кнопку ОК.

Рис.36



                КАК ИЗМЕНИТЬ МЕТКУ ДИСКА
1. “Выбрать” меню DISK -> LABEL DISK. На экране появится диалог 

   LABEL DISK(рис.37).

2. Ввести новую метку и “нажать” ОК.

Рис.37


       КАК РАЗРЕШИТЬ СЕТЕВОЙ ДОСТУП К СВОЕМУ КАТАЛОГУ
1. “Выбрать” меню DISK -> SHARE AS. На экране появится диалог 

   SHARE DIRECTORY(рис.38).

2. Ввести информацию и “нажать” ОК.

Рис.38


Краткое описание Диалога Share Directory(рис.38) :
Share Name - СЕТЕВОЕ имя Каталога(это имя будет в списке доступных

каталогов данного компьютера,см.рис.40)

Path - Полное Имя Каталога

Comment - комментарий к Share Name(комментарий также будет виден

в списке доступных каталогов данного компьютера)

Re-Share at Startup - если этот CheckBox находится в состоянии ВКЛ.,

то каждый раз, при запуске WINDOWS FOR WORKGROUPS, этот каталог

будет открываться для сетевого доступа.

Access Type -> Read-Only - тип разрешенного доступа : ТОЛЬКО ДЛЯ ЧТЕНИЯ
Access Type -> Full - тип разрешенного доступа : ПОЛНЫЙ ДОСТУП
Access Type -> Depends on Password - тип разрешенного доступа : в зави-
симости от пароля(Read-Only или Full)


ВНИМАНИЕ !!!

НЕ желательно менять информацию в диалоге(рис.38) в то время,

когда данный каталог кто-либо использует в сети. Это приведет

к разрыву всех сетевых связей других Пользователей с данным каталогом.

     КАК ЗАПРЕТИТЬ СЕТЕВОЙ ДОСТУП К СВОЕМУ КАТАЛОГУ
1. “Выбрать” меню DISK -> STOP SHARING. На экране появится диалог 

    STOP SHARING DIRECTORY(рис.39).

2. Выбрать соответствующий каталог и “нажать” ОК.

Рис.39


КАК “СДЕЛАТЬ” СЕТЕВОЕ СОЕДИНЕНИЕ С КАТАЛОГОМ ДРУГОГО КОМПЬЮТЕРА

1. “Выбрать” меню DISK -> CONNECT NETWORK DRIVE. На экране появится диалог CONNECT NETWORK DRIVE(рис.40).

2. Выбрать соответствующий свой виртуальный диск.

3. Выбрать соответствующую сетевую группу.

4. Выбрать соответствующий сетевой компьютер.

5. Выбрать соответствующий каталог и “нажать” ОК.

Рис.40


Краткое описание Диалога Connect NetWork Drive(рис.40) :
Drive(ComboBox) - список всех доступных на данном компьютере вирту-

альных логических дисков(кол-во вирт.дисков задано в команде LASTDRIVE 

файла CONFIG.SYS).В это число входят как “свободные” вирт.диски,так и

уже имеющие сетевое соединение.

Path(ComboBox) - ПОЛНОЕ СЕТЕВОЕ имя Каталога(в этом списке “хранится”

“история” сетевых соединений.Поэтому, иногда проще,чем заново задавать

путь сетевого доступа, поискать в этом списке подходящую строку).

Reconnect on Startup - если этот CheckBox находится в состоянии ВКЛ.,

то каждый раз, при запуске WINDOWS FOR WORKGROUPS, это соединение

будет автоматически восстанавливаться(если это возможно).

Show Shared Directories on(ListBox)- список рабочих групп и сетевых

компьютеров.

Shared Directories on(ListBox) - список доступных в сети каталогов

выбранного сетевого компьютера.

Если сетевое соединение выполняется в первый раз(или,если “хозяин”

сетевого каталога изменил информацию в диалоге,см.рис.38) - на экран

выдается запрос на ввод пароля для доступа(рис.41).

Рис.41


Пользователь должен ввести пароль(Password) и “нажать” ОК.

Естественно, что ввод неправильного пароля к достижению вожделенной

цели не приведет.

Если CheckBox Save this Password in Your Password List имеет состояние

ВКЛ. - File Manager “запомнит” пароль и, в дальнейшем(пока хозяин

не изменит пароль), диалог(рис.41) выдаваться на экран не будет.

КАК ПРЕРВАТЬ СЕТЕВОЕ СОЕДИНЕНИЕ С КАТАЛОГОМ ДРУГОГО КОМПЬЮТЕРА

1. “Выбрать” меню DISK -> DICONNECT NETWORK DRIVE. На экране появится диалог DICONNECT NETWORK DRIVE(рис.42).

2. Выбрать соответствующий свой виртуальный диск.

3. “Нажать” кнопку ОК.

Рис.42


Если какое-либо DOS-приложение использует данный виртуальный диск -

File Manager НЕ может прервать данное сетевое соединение. В этом

случае на экране появится сообщение(рис.43). Пользователь должен

“войти” в это DOS-приложение, “освободить” данный виртуальный диск

и повторить пункты 1-3.

Рис.43


КАК,ИСПОЛЬЗУЯ FILE MANAGER,ВСТАВИТЬ ИКОНКИ В PROGRAM MANAGER.

1. Сделать так, чтобы в DeskTop были видимыми :

     - дочернее окно(группа) Program Manager,

     - “выбранные” файлы в File Manager,

2. Используя Drag and Drop перетащить “выбранные” файлы

   в клиентную область окна группы Program Manager.

                 НАСТРОЙКА FILE MANAGER
   ЗАПРОСЫ НА ПОДТВЕРЖДЕНИЕ НАМЕРЕНИЙ ПОЛЬЗОВАТЕЛЯ
1. Выбрать меню Options -> Confirmation.На экране появится диалог

CONFIRMATION(рис.44). Нужно сделать необходимые настройки и “нажать”

кнопку ОК.

Рис.44


Краткое описание Диалога Confirmation(рис.44) :
File Delete - если ВКЛ.,то перед удалением файлов следует дополни-

тельный запрос на подтверждение.

Directory Delete - если ВКЛ.,то перед удалением каталогов следует 

дополнительный запрос на подтверждение.

File Replace - если ВКЛ.,то перед тем как заменить один файл на другой 

с таким же именем,следует дополнительный запрос на подтверждение.

Mouse Action - если ВКЛ.,то при любых действиях Drag and Drop следует 

дополнительный запрос на подтверждение.

Disk Commnads - если ВКЛ.,то при операциях с дискетами следует дополни-

тельный запрос на подтверждение.

  ОБЪЕКТЫ, ОТОБРАЖАЕМЫЕ В АКТИВНОМ ДОЧЕРНЕМ ОКНЕ.

1. Выбрать меню View -> By File Type.На экране появится диалог

By File Type(рис.45). Нужно сделать необходимые настройки и “нажать”

кнопку ОК.

Рис.45
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Краткое описание Диалога By File Type(рис.45) :

Name - маска файлов,которые будут показаны в активном дочернем окне.

Directories - если ВКЛ., то будут показаны каталоги.

Programs - если ВКЛ., то будут показаны программные файлы.

Documents - если ВКЛ., то будут показаны файлы-документы.

Other File - если ВКЛ., то будут показаны файлы всех типов.

Show Hidden/System Files - если ВКЛ., то будут показаны скрытые и 

системные файлы.

Остальные настройки достаточно просты(см.табл.N1) и здесь НЕ 

приводятся.
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В рамках данной темы рассмотрены лишь основные 

возможности File Manager.
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